Kernelul 4.13.0-32: Dificultăţi în Mint 18.3

Grafica articolului "Kernelul 4.13.0-32: Dificultăţi în Mint 18.3"

Bun venit şi lectură plăcută!

Astăzi voi scrie pe scurt despre un experiment cu kernelul 4.13.0-32.

Întrucât din 11-01-2018 am primit în lista de update şi acest kernel, lucru pe care l-am anticipat de fapt în articolele din seria “Rolling Release sau Point Release”, în care am spus că Mint 18.3 va avea ca kernel final versiunea 4.13.0.x şi am anunţat că a apărut, în “Kernel: Rezultate experimentale cu Linux Mint 18.2 (18.3)”, mi-am făcut timp să testez această versiune, dat fiind faptul că de la data apariţiei, “numărătoarea inversă” ticăie. Anume, suportul pentru Kernelul 4.10.0.x, va înceta curând. Atât timp cât kernelul a ajuns la versiunea stabilă 4.14.15 şi mainline la 4.15.RC9, este dificil de ştiut cât timp voi mai avea suport pentru versiunea 4.10.0.x…

Probleme cu kernelul 4.13.0-x

Potrivit situaţiei concrete, kernelul final al Linux Mint 18.3, este 4.13.0-x.

Iată câteva dintre dificultăţile cu care m-am confruntat, în cele două zile cât m-am străduit să lucrez cu el:

  • Crashuri OpenShot v 2.4.1. Cum am mai spus, pentru mine este vorba despre producţie şi OpenShot a fost greu pus la încercare după upgrade la 4.13.0!
  • Probleme mari la copierea fişierelor pe stick USB. Viteza de scriere pe medii flash, a scăzut dramatic! De la o viteză medie de 3 MB/sec, am ajuns la sub 1 MB/sec!
  • Probleme cu recunoaşterea HDD. Am avut un şoc atunci când mi s-a propus să bootez de pe CD-ROM! M-am uitat în BIOS şi am constatat că până şi ordinea de boot fusese modificată! Cum e posibil aşa ceva? Aveam pus pe primul loc CD intern, apoi USB HDD şi abia pe ultimul loc “Internal SATA”, dar fără vreo specificaţie. A trebuit să dau reboot ca să reapară HDD-ul intern în listă, HDD care are abia vreo 6 luni de funcţionare!
  • Funcţionare anormală a aplicaţiilor. Mai sunt şi alte aplicaţii care s-au comportat dubios. Singura pe care am remarcat-o şi am putut să o identific clar, a fost Thunar. Dacă Thunar e cunoscut pentru regresiile pe care le provoacă, teoretic, se poate pasa răspunderea pe acest program. Totuşi, problema se află în cu totul altă parte, altfel, cum se explică funcţionarea OK sub kernelul 4.10.0-42?
  • Probleme cu lampa backlit (CCFL, Cold Cathode Fluorescent Lamp). După primele ore de lucru, a fost nedetectabilă. După primul reboot însă, fluctuaţiile luminozităţii au devenit vizibile. Este o problemă foarte gravă, pentru că arderea lămpii, înseamnă costuri de înlocuire, undeva între 250 şi 350 lei din câte am văzut eu pe la firmele care vând componente SH. Într-o astfel de situaţie am deja două laptopuri şi rezolvarea, mă depăşeşte ca costuri. Prefer să cumpăr un monitor sau un televizor cu display LED, care mă costă cam jumătate, la SH.

Ce spune documentarea?

Am consumat vreo 3 ore tot răscolind pe net, puţin şi pentru scrierea articolului, dar în mare măsură, din dorinţa de a clarifica ce se întâmplă.

Am găsit câteva zeci de articole cu privire la mari probleme ale kernelului 4.13.x cu driverele video. În mod particular, gama de chipseturi Intel, este foarte foarte grav afectată. În aceste condiţii, sunt nevoit să revin la kernelul LTS, care este 4.4.0-x.

Am întâlnit din nefericire, o mulţime de chipseturi şi mai noi şi mai vechi, unele chiar foarte vechi aş zice, care sunt afectate.

Dacă aş avea timp să aloc citirii de articole poate că aş face-o, dar ce mă interesează pe mine este să rezolv cumva problema.

Dincolo de pierderea foarte mare de performanţă, constat că sunt afectate multe aplicaţii.

Dacă până acum am pus pe seama vechimii laptopului, acum constat că de fapt, este vorba despre kernel, care are o mulţime de buguri care afectează sistemul video şi de aici încolo, e o infinitate de posibilităţi ca ceva să meargă prost. Am găsit postări pe forumuri în care se prezintă şi dificultăţi la desenarea şi redarea ecranelor text, ori meniul GRUB, este un astfel de ecran!

Ce se petrece de fapt? Unde sunt erorile, pentru că driverele sunt aceleaşi şi de vreme ce au mers la alte versiuni de kernel, e clar că trebuie să meargă şi la noile versiuni de kernel!

De unde sunt pierderile de performanţă la 4.13.x?

Deşi oficialii se feresc să discute pe tema asta, dacă ne uităm la bugurile semnalate, constatăm că problemele cu chipseturile video sunt din ce în ce mai multe şi din ce în ce mai grave. În aceste condiţii, mi-e greu să întrevăd o altă soluţie decât revenirea la configuraţia cea mai stabilă şi cea mai performantă.

Asta înseamnă în cazul cel mai bun, versiunea de kernel 4.10.0-42 şi ce va mai apare, dacă va mai apare o actualizare….

Cea mai sigură soluţie însă, rămâne revenirea la kernelul LTS 4.4.0, care am văzut că primeşte constant actualizări.

Se poate înlocui sistemul video?

Răspunsul teoretic, este da. Din nefericire însă, există aceeaşi problemă şi acolo: suportul; driverele proprietare.

Dacă driverele pentru chipseturile vechi, integrate, crează probleme mari, mi-e imposibil să visez cu ochii deschişi cum că, pentru un sistem video USB, driverele vor fi “top-notch”. La asta, se adaugă şi preţul unui adaptor video de vârf, care începe de pe la 1000 euro şi ajunge la peste 3000 euro!

În astfel de condiţii, singura soluţie cât de cât aplicabilă, este alt calculator! Adică, o luăm de la capăt cu calvarul driverelor şi al compatibilităţilor hardware!

Închei aici această prezentare şi îmi exprim speranţa că am oferit măcar câteva informaţii utile celor care au început să aibă probleme cu calculatoarele.

Deşi sunt conştient că rezolvarea lor e o chestiune dificilă, cel puţin am oferit nişte informaţii care să poată fi folosite la prevenirea unor dezastre hardware.

Te invit la final, VINERI, la o nouă excursie în lumea Linux!

– Citit de 94 vizitatori

2 thoughts on “Kernelul 4.13.0-32: Dificultăţi în Mint 18.3

    • Salut!
      Pe moment, văd că merge kernelul 4.10.0. Dacă vor apare probleme însă, pot trece foarte simplu la kernelul 4.4.0.
      Metodologia pe care am folosit-o îmi permite să revin la orice configuraţi am avut şi mi-a convenit.
      O soluţie pe care am testat-o şi merge (deocamdată) este TimeShift.
      Dar am şi backupuri low-level, făcute cu CloneZilla.
      Aşadar, dacă lucrurile iau o întorsătură neplăcută, revin evident la 4.4.0, care este un LTS oficial.
      Primul care are suport pe 6 ani (până în 2022).

Lasă-mi părerea ta!